Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby wiscownsin » Sat Dec 05, 2015 12:33 pm

Just got a brand new Grand Prime last week. The 4G LTE worked for 5 days, then quit. It only runs data on wifi or 3G now. I've tried power cycling the phone off/on, restart, *22890 programming, turning the mobile data off and on. Nothing works. I bought this phone specifically for faster data, and am not getting what I paid for! Please HELP!
wiscownsin
 
Posts: 4
Joined: Sat Dec 05, 2015 12:26 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby ST-Kurt » Sat Dec 05, 2015 12:41 pm

Hi wiscownsin! Our apology for the inconvenience. I am Straight Talk Kurt. We need to take this issue offline so I can address it. I will contact you directly with a private message. Thanks!
ST-Kurt
 
Posts: 2046
Joined: Thu Aug 07, 2014 3:09 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby wiscownsin » Mon Dec 07, 2015 8:03 am

Live chat tech support had me do a hard reset (pulling the battery out while the phone is turned on), and that still didn't work, now what?
wiscownsin
 
Posts: 4
Joined: Sat Dec 05, 2015 12:26 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby wiscownsin » Mon Dec 07, 2015 8:06 am

Also, yahoo notifications only come thru when phone is on WiFi. They don't notify at all on 3G mobile data, you have to manually refresh and retrieve new emails from within the app. When LTE used to work, this wasn't an issue.
wiscownsin
 
Posts: 4
Joined: Sat Dec 05, 2015 12:26 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby wiscownsin » Tue Dec 15, 2015 2:18 pm

FOLLOW UP:

I called tech support via the ST 800 number. Make sure to call from a different phone than the one having trouble. They talked me through the usual "check this, check that" troubleshooting. They have to do this first, just to make sure I had everything set right on my phone. Then, they said they'd send a new SIM card. I received the card in the mail rather quickly, and called tech support back per the enclosed instructions. They talkedme through installation and activating the new SIM card (wait to install until they tell you to). Everything is working properly as it should again. I once again have full speed LTE and am getting email notifications pushed properly. Hopefully this problem will stay resolved and not come back. If it does, I'll post back here. If not, it's safe to assume that everything is good.
wiscownsin
 
Posts: 4
Joined: Sat Dec 05, 2015 12:26 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby waldo177 » Mon Dec 21, 2015 9:23 pm

I am having the same issue only seemed to effect it after I did the *22890 though, been on the phone with them multiple times and they keep telling me its my towers but I bought my son the same phone and it is working fine on lte. I am wondering if I just buy a new sim card and install it my self if I can get it to work?
waldo177
 
Posts: 4
Joined: Mon Dec 21, 2015 9:13 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby ST-Jean » Mon Dec 21, 2015 9:36 pm

Hi waldo177! My name is Straight Talk Jean. Sorry that you’re having a problem. I will contact you directly with a private message. Thank you.
ST-Jean
 
Posts: 2370
Joined: Fri Aug 08, 2014 5:56 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby msFiyared » Sat Jan 09, 2016 8:11 am

I need help my phone has been stuck on 3g since i got it
msFiyared
 
Posts: 2
Joined: Thu Dec 24, 2015 8:04 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby ST-Kurt » Sat Jan 09, 2016 9:30 am

Hi msFiyared! This is Straight Talk Kurt. I will contact you directly with a private message. Thank you.
ST-Kurt
 
Posts: 2046
Joined: Thu Aug 07, 2014 3:09 pm

Re: Samsung Galaxy Grand Prime SM-S920L LTE doesn't work

Postby hisbeauty4ashes » Fri Jan 22, 2016 12:59 pm

To whom it may concern. I wrote the fallowing.

hisbeauty4ashes wrote:
I bought a Samsung Galaxy Grand Prime ST phone a couple of months ago. The LTE was working fine but then it would go in and out. Now it switched to 3g. I contacted ST too and went through this process with them. Then they tell me oh it does that some times. Well it is not working at all and I am very disappointed. I paid over $200 for this phone it needs to work properly or I should get my money back. I look on the forum and it looks like it is a flaw with St Grand Prime phones.

Can someone please help me fix this issue, or replace it.

Thank you

They tell me to click a certain link to talk to an agent and they do not give me a ticket number. I can reply to the agent on my privet message to tell them I have already talked to a live agent and got totally no where.

Will some one help me with this issue.

Thanks you.
hisbeauty4ashes
 
Posts: 7
Joined: Sun Apr 20, 2014 11:27 pm

Next

Return to Samsung

Who is online

Users browsing this forum: No registered users and 1 guest